ffdshow does not show PGS subtitles.

View previous topic View next topic Go down

ffdshow does not show PGS subtitles.

Post by shiki321 on Mon Apr 07, 2014 5:43 pm

Hello.

I have a small issue with ffdshow not showing PGS subtitles. This occured when I (finally) did the switch to win7. I had no such problems on xp, where I used haali splitter + ffdshow to show the subs.
It works fine with LAV splitter and decoder so it doesn't kill me but it certainly bugs me.
I've tried fiddling with the codec tweak tool but to no awail.

I use the latest version of the pack (mega) and as stated above, I'm on win7 (64 bit)
I'd appreciate some help with this.

Thanks in advance

shiki321

Posts : 4
Join date : 2014-04-07

View user profile

Back to top Go down

Re: ffdshow does not show PGS subtitles.

Post by Admin on Tue Apr 08, 2014 1:23 am

You don't need ffdshow for subtitles. MPC-HC contains an internal subtitle renderer. When using WMP, the codec pack uses xy-VSFilter (aka DirectVobSub) by default for subtitles.

Can you give me a link to a file that isn't working for you?

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: ffdshow does not show PGS subtitles.

Post by shiki321 on Tue Apr 08, 2014 1:49 am

I did not know directvobsub had support for PGS. That doesn't even load for me on .m2ts files.
The files I'm testing with is blurays I've ripped myself so linking wouldn't be an option.

If I use haali splitter + ffdshow decoder, I cannot even select any subtitle stream (It doesn't find any?)
If I use LAV splitter + ffdshow, I can select a subtitle stream but it doesn't show.
LAV splitter + LAV decoder works perfectly.

It's not likely that there is a problem with the files I am trying with seeing as they worked before so I think there is a problem in the settings.

shiki321

Posts : 4
Join date : 2014-04-07

View user profile

Back to top Go down

Re: ffdshow does not show PGS subtitles.

Post by Admin on Tue Apr 08, 2014 2:18 am

If Haali does not show any subtitle streams, then it indeed means it did not find any. Haali works the same on XP as it does on Windows 7. Haali Splitter is no longer actively being developed. It is recommended to use LAV Splitter.

Did you crop or resize the video when ripping?
Which player are you using?

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: ffdshow does not show PGS subtitles.

Post by shiki321 on Tue Apr 08, 2014 3:01 am

Even if I use LAV and choose a subtitle stream, it does not show tho (aslong as I use ffdshow decoder). That's what's confusing me.

Nothing was altered during the ripping, the video files are 100% "pure".

I am using WMP

shiki321

Posts : 4
Join date : 2014-04-07

View user profile

Back to top Go down

Re: ffdshow does not show PGS subtitles.

Post by Admin on Tue Apr 08, 2014 6:15 am

Codec Tweak Tool > Preferred Decoders > H.264 must be set to "Use merit"
Codec Tweak Tool > MS Codec Tweaks > Disable Media Foundation and MS DTV-DVD Video decoder

That should work.

I really recommend using MPC-HC as player. That works out-of-the-box without tweaks/hacks. WMP12 has a lot of limitations.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: ffdshow does not show PGS subtitles.

Post by shiki321 on Tue Apr 08, 2014 2:54 pm

Thank you good sir. Works like a charm now.

I might consider going over to MPC-HC if something else goes wrong.

shiki321

Posts : 4
Join date : 2014-04-07

View user profile

Back to top Go down

Re: ffdshow does not show PGS subtitles.

Post by Sponsored content Today at 9:27 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum