Arabic subtitles are showing up as symbols no matter what i do

View previous topic View next topic Go down

Arabic subtitles are showing up as symbols no matter what i do

Post by Samars on Mon Mar 10, 2014 11:52 am

hey, please i need help

i use windows 8, and i am not very good with computers though i know enough to get by and am good at using google, however recently i have come across this problem, ad after trying almost all the methods mentioned in previous similar questions at different sites i am still encountering the same problem.

arabic subtitles always look something like this
Úáì ÈõÚÏ 600 ßíáæ ãÊÑ ÝæÞ ßæßÈ ÇáÃÑÖ¡ ÏÑÌÉ
.ÇáÍÑÇÑÉ ÊÊøÑÇæÍ Èíä +285 æ -148 ÏÑÌÉ ÝåÑäåÇíÊíÉ


i tried first changing the player, (hiplayer, mpcstar, windows media player classic, vlc, windows media player,)

when that didn't work i thought there was a problem with the actual subtitle file, so i downloaded different ones, from different sites, and different extentions (.srt, .sub) but nothing worked

i googled the problem and 90% of people said the problem was that the srt file was saved with a font incompatible with arabic, or that the encoding needs to be changed to UTF-8 , UNICODE, ANSI i changed the font to arabic and in the sample it shows arabic clearly, i tried the sub after saving it as UTF-8, Unicode, and ANSI and everytime i came across the same wierd symbols

my computer supports arabic i think, because it normally allows me to open read and edit documents written in arabic, however when i open the srt file in notepad this is what i see

1
00:00:04,106 --> 00:00:13,775
<font color=#0080ff> ÊÜÜÜÑÌãÉ æ ÊÚÏíá</font>
<font color=#008000>|| ÇáÏßÊæÑ Úáí ØáÇá & ÃäÓ ÇáÌäÇÈíø ||</font>

1
00:00:14,106 --> 00:00:21,775
<font color=#0080ff>Úáì ÈõÚÏ 600 ßíáæ ãÊÑ ÝæÞ ßæßÈ ÇáÃÑÖ¡ ÏÑÌÉ
.ÇáÍÑÇÑÉ ÊÊøÑÇæÍ Èíä +285 æ -148 ÏÑÌÉ ÝåÑäåÇíÊíÉ</font>

2
00:00:23,015 --> 00:00:25,466
<font color=#0080ff>.áÇ íõæÌÏ æÓøíØ áäÞá ÇáÕæÊ</font>



Can someone please please please please help me O_O  Sad 

Samars

Posts : 6
Join date : 2014-03-10

View user profile

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Admin on Tue Mar 11, 2014 2:17 am

You don't need to modify the subtitles files. The changes you made are also invalid.

Do this:
MPC-HC options > Subtitles > Default Style > click on "DEFAULT (1)" and change it to "ARABIC (178)".
This will change the 'code page' and characters should then be displayed correctly.

Admin
Admin

Posts : 2979
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Samars on Tue Mar 11, 2014 3:03 pm

first thank you for responding i really apreciate it

second i can't find the item subtitles in the MPC Options, let me describe what i did

1) i opened MPC star,
2) right click, and chose OPTIONS from the menu that appeared
3) i looked for the item subtitles but couldn't find it, this is what it looked like

https://i56.servimg.com/u/f56/18/77/94/37/n11.png

if i am doing something wrong can you please tell me what to do?

Samars

Posts : 6
Join date : 2014-03-10

View user profile

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Admin on Wed Mar 12, 2014 3:34 am

MPCStar is not in any way related to the codec pack. The player from the codec pack is called "MPC-HC" (also know as Media Player Classic).

Admin
Admin

Posts : 2979
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Samars on Wed Mar 12, 2014 11:52 pm

hello again,
forst thank you so much for taking the time to help me

second, i regret to inform you that i did as you said exactly and it didn't work  Sad Sad 

MPC-HC options > Subtitles > Default Style > click on "DEFAULT (1)" and change it to "ARABIC (178)".
This will change the 'code page' and characters should then be displayed correctly.

still got the gibberish when i actually tried to play the movie

is there something else i can try?

thank you again

Samars

Posts : 6
Join date : 2014-03-10

View user profile

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Admin on Thu Mar 13, 2014 7:10 am

If you are using Windows XP then:
Start > Programs > K-Lite Codec Pack > Configuration > DirectVobSub > Main > Text Settings > click on Arial > select "Arabic (178)"

Admin
Admin

Posts : 2979
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Samars on Thu Mar 13, 2014 10:11 am

no am using windows 8  Sad 

Samars

Posts : 6
Join date : 2014-03-10

View user profile

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Admin on Fri Mar 14, 2014 4:23 am

Maybe this helps:
MPC-HC options > Subtitles > Default Style > Arial > change script from "Western" to "Arabic"

Admin
Admin

Posts : 2979
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Samars on Sat Mar 15, 2014 3:53 am

I Opened it to turn the script to arabic, found that it already is Sad Sad

Samars

Posts : 6
Join date : 2014-03-10

View user profile

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Admin on Sat Mar 15, 2014 5:45 am

Then I don't know what is wrong.

Does the text display correctly when you open the original unmodified file in Notepad?

Admin
Admin

Posts : 2979
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Samars on Sat Mar 15, 2014 8:23 am

i thought there was a problem with the actual subtitle file, so i downloaded different ones, from different sites, and different extentions (.srt, .sub) but nothing worked

my computer supports arabic i think, because it normally allows me to open read and edit documents written in arabic, however when i open the srt file in notepad this is what i see

1
00:00:04,106 --> 00:00:13,775
<font color=#0080ff> ÊÜÜÜÑÌãÉ æ ÊÚÏíá</font>
<font color=#008000>|| ÇáÏßÊæÑ Úáí ØáÇá & ÃäÓ ÇáÌäÇÈíø ||</font>

1
00:00:14,106 --> 00:00:21,775
<font color=#0080ff>Úáì ÈõÚÏ 600 ßíáæ ãÊÑ ÝæÞ ßæßÈ ÇáÃÑÖ¡ ÏÑÌÉ
.ÇáÍÑÇÑÉ ÊÊøÑÇæÍ Èíä +285 æ -148 ÏÑÌÉ ÝåÑäåÇíÊíÉ</font>

2
00:00:23,015 --> 00:00:25,466
<font color=#0080ff>.áÇ íõæÌÏ æÓøíØ áäÞá ÇáÕæÊ</font>

Samars

Posts : 6
Join date : 2014-03-10

View user profile

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Admin on Mon Mar 17, 2014 4:53 am

Can you give me a link to one of those .srt files? Then I can test it on my own computer.

Admin
Admin

Posts : 2979
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by sqweezy on Wed Dec 24, 2014 9:53 am

i was just getting the same problem as you ...

i solve it .. its very simple ..

open the classic media player then go to :

play ---> subtitles ---> styles --->then change it from"DEFAULT (1)" to "ARABIC (178)"

and im sure that it well be solved ..

by the way .. i was looking for an solution so i just registered to tell you the solution

regards

sqweezy

Posts : 1
Join date : 2014-12-24

View user profile

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by NARANJAGRATIS on Tue Nov 24, 2015 4:30 pm

Samars wrote:hello again,
forst thank you so much for taking the time to help me

second, i regret to inform you that i did as you said exactly and it didn't work  Sad Sad 

MPC-HC options > Subtitles > Default Style > click on "DEFAULT (1)" and change it to "ARABIC (178)".
This will change the 'code page' and characters should then be displayed correctly.

still got the gibberish when i actually tried to play the movie

is there something else i can try?

thank you again
Kind of a late reply, you may not need an answer any more.
In Media Player Classic, try this:
Options > Playback > DVD/OGM > "Preferred language for DVD Navigator and the external OGM Splitter" > Click on Subtitles > I chose Arabic (Egypt) > Press OK then restart the player.
Hope this works, it worked for me after changing Style to "ARABIC (178)"

NARANJAGRATIS

Posts : 2
Join date : 2015-11-24

View user profile

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Admin on Wed Nov 25, 2015 1:44 am

Yes, that will work for DVD subtitles.

The other setting is for subtitles for other video types.

Admin
Admin

Posts : 2979
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by NARANJAGRATIS on Wed Nov 25, 2015 1:54 am

Admin wrote:Yes, that will work for DVD subtitles.

The other setting is for subtitles for other video types.

That's what I thought, too, but that's what solved my problem. It actually worked for videos (i don't use dvd's).
Maybe MPC treats some videos as a DVD.

NARANJAGRATIS

Posts : 2
Join date : 2015-11-24

View user profile

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Admin on Wed Nov 25, 2015 2:36 am

Maybe it uses that for VobSub types subtitles (.idx/.sub) as that is the format used by DVDs. The other setting then works for text-based subtitles like SRT.

Admin
Admin

Posts : 2979
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Arabic subtitles are showing up as symbols no matter what i do

Post by Sponsored content Today at 1:33 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum