Mega 10.20 breaks WMP11 on XP x64 (fixed, but not sure by who)

View previous topic View next topic Go down

Mega 10.20 breaks WMP11 on XP x64 (fixed, but not sure by who)

Post by Kurt_Aust on Fri Jan 17, 2014 7:13 pm

OS: Windows XP Professional x64 edition (fully updated)

If the K-Lite Mega codec pack version 10.20 is installed then when one tries to play a video with Windows Media Player 11 it immediately closes as if the process had been killed, there is no error message given.

If K-Lite Mega 10.20 is uninstalled then one can play the file in WMP11 for audio only.

If K-Lite Mega 10.15 is installed then WMP11 can play videos normally.

Media Player classic works properly when either 10.20 or 10.15 is installed.


Last edited by Kurt_Aust on Mon Jun 09, 2014 7:57 am; edited 1 time in total

Kurt_Aust

Posts : 4
Join date : 2013-08-17

View user profile

Back to top Go down

Re: Mega 10.20 breaks WMP11 on XP x64 (fixed, but not sure by who)

Post by Admin on Sat Jan 18, 2014 4:45 am

Does it happens with any type of video? Also if no subtitles are present?

Look in Control Panel > System > Administrative Tools > Event Viewer > Windows Logs > Application
There you may be able to find a crash log. If so, look at the "Faulting module name".

Admin
Admin

Posts : 2986
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Mega 10.20 breaks WMP11 on XP x64 (fixed, but not sure by who)

Post by Kurt_Aust on Sat Jan 18, 2014 8:58 am

It appears to be any type of video, .avi, .mov &.rm tested, none of which loaded a subtitle file.

Further investigation reveals that Mega 10.20 trips "Simulate execution flow" protection.

http://download.microsoft.com/download/7/A/A/7AA570E7-92DF-4C28-BE12-E72831797666/EMET%20User%27s%20Guide.pdf

Kurt_Aust

Posts : 4
Join date : 2013-08-17

View user profile

Back to top Go down

Re: Mega 10.20 breaks WMP11 on XP x64 (fixed, but not sure by who)

Post by Admin on Mon Jan 20, 2014 7:39 am

Could be a false positive detection in EMET. You should disable that mitigation for MPC-HC. EMET v4.0 also had a false positive for MPC-HC, which was fixed in EMET v4.1.

Admin
Admin

Posts : 2986
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Mega 10.20 breaks WMP11 on XP x64 (fixed, but not sure by who)

Post by Kurt_Aust on Mon Jan 20, 2014 5:02 pm

Well at least you know about it, as EMET targets suspicious behaviour rather than known malware, it wouldn't be at all surprising if other security programs start flagging it.

Kurt_Aust

Posts : 4
Join date : 2013-08-17

View user profile

Back to top Go down

Re: Mega 10.20 breaks WMP11 on XP x64 (fixed, but not sure by who)

Post by Admin on Tue Jan 21, 2014 5:07 am

Enabling "deep hooks" option in EMET 4.1 may solve the false positive from what I have heard.

Admin
Admin

Posts : 2986
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Mega 10.20 breaks WMP11 on XP x64 (fixed, but not sure by who)

Post by Kurt_Aust on Mon Jun 09, 2014 7:56 am

I'm not sure if it's due to changes in EMET 4.1 update 1 or K-Lite Mega Codec 10.5.5 but this problem has been resolved under default EMET settings.

Kurt_Aust

Posts : 4
Join date : 2013-08-17

View user profile

Back to top Go down

Re: Mega 10.20 breaks WMP11 on XP x64 (fixed, but not sure by who)

Post by Sponsored content Today at 10:55 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum