Dependence MKV upon TS splitter in 10.2.x

View previous topic View next topic Go down

Dependence MKV upon TS splitter in 10.2.x

Post by vramor on Sat Jan 11, 2014 8:51 am

There is a rather strange dependence TS splitter upon MKV one which I noticed starting with KLCP 10.2.0.
After the installing of 10.2.x KLCP with the default settings and choosing Haali splitter for TS I get the new prechoosen option for MKV instead of LAV:
Unknown source filter:{55DA30FC-F16B-49FC-BAA5-AE59...
After I choose LAV splitter for MKV again this option disappears.
What it may be and why?

vramor

Posts : 127
Join date : 2011-07-29

View user profile

Back to top Go down

Re: Dependence MKV upon TS splitter in 10.2.x

Post by Admin on Mon Jan 13, 2014 4:54 am

Haali splitter sets itself as default when registering. This is normally corrected by the installer. However, when a reboot is required, then registration is delayed till after the reboot. The installer can't fix anything in that case.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Dependence MKV upon TS splitter in 10.2.x

Post by vramor on Mon Jan 13, 2014 2:24 pm

Maybe I couldn't explain what things seem strange to me with 10.2.x configuration after installation. I'll try once more.
1. I install 10.2.x. All the configuration features are default.
2. Try to play multiservice .TS file. Only one service is playing back.
3. Run Codec Tweak Tool -> Preferred splitters, choose Haali for .TS, Apply & Close
4. Multiservice .TS are playing OK. Try to play .MKV with HEVC - no picture, only audio
5. Find out the reason, run CTT again, and see "Unknown source filter..." for .MKV
6. Choose LAV for .MKV, Apply & Close
7. Everything is OK now.
My question is: Is the such configuration procedure normal now?

vramor

Posts : 127
Join date : 2011-07-29

View user profile

Back to top Go down

Re: Dependence MKV upon TS splitter in 10.2.x

Post by Admin on Tue Jan 14, 2014 1:00 am

Now I understand. It is a bug in CTT, not adjusting preferred mkv splitter after enabling haali. It will be fixed.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Dependence MKV upon TS splitter in 10.2.x

Post by vramor on Wed Jan 15, 2014 8:25 pm

With 10.2.5 there is no problem anymore! Thank you!

vramor

Posts : 127
Join date : 2011-07-29

View user profile

Back to top Go down

Re: Dependence MKV upon TS splitter in 10.2.x

Post by vramor on Fri Jan 17, 2014 10:28 am

Sorry, but I've jumped to a husty conclusion of unproblematic 10.2.5 update. If 10.2.5 update is installed immediately on 10.2.0 Full KLCP with defaults there is not any possibility to choose Haali splitter for .TS files at all. LAV only! But LAV cannot provide the playing multiservice .TS files! So I uninstalled 10.2.5, installed 10.2.0, then 10.2.4, and 10.2.5 at last. Then I run CTT and configured KLCP choosing Haali splitter for .TS files. That's all.

vramor

Posts : 127
Join date : 2011-07-29

View user profile

Back to top Go down

Re: Dependence MKV upon TS splitter in 10.2.x

Post by Admin on Sat Jan 18, 2014 4:27 am

Works fine here.

10.2.4 doesn't do anything related to Haali, so installing it before 10.2.5 has no effect.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Dependence MKV upon TS splitter in 10.2.x

Post by vramor on Sat Jan 18, 2014 6:30 am

Admin wrote:Works fine here.
10.2.4 doesn't do anything related to Haali, so installing it before 10.2.5 has no effect.

Most likely you are right as usual. But what can I do with this?
I install 10.2.0. That's what CTT says:

Next I install 10.2.5 update

Now CTT says:

And where is my loved Haali? Sad
P.S. I remember your promised of LAV multiservice files support. How long we should wait for this lucky day? Smile Thank you for your time!

vramor

Posts : 127
Join date : 2011-07-29

View user profile

Back to top Go down

Re: Dependence MKV upon TS splitter in 10.2.x

Post by Admin on Mon Jan 20, 2014 6:56 am

Will be fixed.

I have never promised anything regarding MPEG-TS multiple programs support in LAV. I have only said that it is on the ToDo list of the developer of LAV Filters. I can't predict if or when it will be implemented. Could be next month, next year, or maybe never.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Dependence MKV upon TS splitter in 10.2.x

Post by vramor on Tue Jan 21, 2014 6:44 am

Yes! Everything's OK now with 10.2.6 update. Of course the implementation of MPEG-TS multiple programs support in LAV is desirable but all depend on you. Thank you for everything you do! My only desire is to help you to make your product better. Thank you once more!

vramor

Posts : 127
Join date : 2011-07-29

View user profile

Back to top Go down

Re: Dependence MKV upon TS splitter in 10.2.x

Post by Sponsored content Today at 9:28 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum