m2ts no audio

View previous topic View next topic Go down

m2ts no audio

Post by mmTalish33 on Sun Nov 24, 2013 9:13 am

I have installed KLCP Mega on my win 7 machine. i got some m2ts (AVCHD) files. they play well in MPC but there is no audio in WMP. are there any settings in KLCP configuration i must do to get audio of these files in WMP.
Regrads.
avatar
mmTalish33

Posts : 25
Join date : 2011-09-07
Age : 30
Location : Pakistan

View user profile

Back to top Go down

Re: m2ts no audio

Post by Admin on Mon Nov 25, 2013 2:50 pm

WMP uses its own Media Foundation codecs by default for m2ts files. You can make it work the same way as MPC by doing this:
Codec Tweak Tool > Win7DSFilterTweaker > Media Foundation > disable for .m2ts

Admin
Admin

Posts : 3274
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: m2ts no audio

Post by mmTalish33 on Mon Nov 25, 2013 4:01 pm

Admin wrote:WMP uses its own Media Foundation codecs by default for m2ts files. You can make it work the same way as MPC by doing this:
Codec Tweak Tool > Win7DSFilterTweaker > Media Foundation > disable for .m2ts

there is no *.m2ts given in that section
avatar
mmTalish33

Posts : 25
Join date : 2011-09-07
Age : 30
Location : Pakistan

View user profile

Back to top Go down

Re: m2ts no audio

Post by Admin on Tue Nov 26, 2013 1:59 pm

Sorry, I forgot that option is only available in Windows 8. On Windows 7 you need to go to the "MS Codec Tweaks" page and disable the Microsoft DTV-DVD audio decoder. If that doesn't help, then you can disable Media Foundation completely on that same page, but that should be used as a last resort.

Admin
Admin

Posts : 3274
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: m2ts no audio

Post by mmTalish33 on Wed Nov 27, 2013 9:58 am

Admin wrote:Sorry, I forgot that option is only available in Windows 8. On Windows 7 you need to go to the "MS Codec Tweaks" page and disable the Microsoft DTV-DVD audio decoder. If that doesn't help, then you can disable Media Foundation completely on that same page, but that should be used as a last resort.
I got sound. but by disabling "Microsoft DTV-DVD audio decoder" along with "Media Foundation"Laughing . just disabling "Microsoft DTV-DVD audio decoder" or "Media Foundation" didn't work. strange:affraid: 
avatar
mmTalish33

Posts : 25
Join date : 2011-09-07
Age : 30
Location : Pakistan

View user profile

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum