High bitrates choppy with MPC-HC but fine with WMP (DXVA issue?!)

View previous topic View next topic Go down

High bitrates choppy with MPC-HC but fine with WMP (DXVA issue?!)

Post by taskmgr on Tue Nov 05, 2013 5:50 am

Hi,
I have a problem playing high bitrate videos (.MTS AVC @ ~20 mbps) even when DXVA is working.

I have been a huge fan of MPC-HC for a long time. I have it all customized to my needs (controls, skin and even the DXVA support for high resolution AVC videos and movies) and everything was fine up until recently. I've come across some high bitrate videos and they were a bit choppy. I thought this was because it was just too high for my old low-end laptop (Intel Atom @ 1.6 but with decent 256MB nVidia GPU), but before giving up, I tried to play the video in Windows Media Player and it played just fine, no lags and choppy playback whatsoever.

I have the Mega Codec Pack installed, with MPC-HC as default, but all videos play in WMP as well (and even without problems Sad ). But I don't want to use WMP, it is not customizable at all.

Is there a way to find out why the same video plays fine in WMP, but choppy in MPC-HC? And it's not just the .MTS file I tried, it plays even huge .MKV movies (that I gave up watching with MPC-HC) without problems. I already tried to reinstall to a newest version and reset all the settings in CodecTweakTool.exe



Any help is greatly appreciated!
taskmgr.

taskmgr

Posts : 3
Join date : 2013-11-05

View user profile

Back to top Go down

Re: High bitrates choppy with MPC-HC but fine with WMP (DXVA issue?!)

Post by Admin on Wed Nov 06, 2013 2:23 am

Try without DXVA.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: High bitrates choppy with MPC-HC but fine with WMP (DXVA issue?!)

Post by taskmgr on Wed Nov 06, 2013 5:35 am

Admin wrote:Try without DXVA.
I'm afraid it definitely won't help because the tiny CPU won't play anything over 3 mbps without the help of the nVidia...

I'm trying to find out what settings of the which codecs are used to play the AVC videos in WMP so I could use the same settings with MPC-HC - I mean, if it works fine in WMP, why can't it work in MPC-HC?

taskmgr

Posts : 3
Join date : 2013-11-05

View user profile

Back to top Go down

Re: High bitrates choppy with MPC-HC but fine with WMP (DXVA issue?!)

Post by Admin on Wed Nov 06, 2013 11:25 am

WMP uses the same video decoding for .mkv files as MPC-HC. At least with default settings.

Try these settings:
1) In LAV Video decoder select "DXVA (native)"
2) MPC-HC options > Playback > Output > Select "Enhanced Video Renderer". That is same as what WMP uses, and a little bit faster the the Custom variant. Only downside is that it doesn't support subtitles when using DXVA, but neither does WMP.
3) MPC-HC options > Internal Filters > Audio Switcher > disable (not needed and improves performance tiny bit)

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: High bitrates choppy with MPC-HC but fine with WMP (DXVA issue?!)

Post by taskmgr on Thu Nov 07, 2013 12:34 am

Thanks Admin,
Advice 1) solved my problem with choppy playback - I had NVIDIA CUVID selected instead of DXVA (native).


Videos and movies at very high bitrates now play smoothly (with subtitles turned off - with subtiles on, there is lag with some movies, but I can cope with that and not watch them with subtitles Smile )

Thanks again,
taskmgr.

taskmgr

Posts : 3
Join date : 2013-11-05

View user profile

Back to top Go down

Re: High bitrates choppy with MPC-HC but fine with WMP (DXVA issue?!)

Post by Admin on Thu Nov 07, 2013 2:41 am

CUVID is similar to DXVA (copy-back). The decoded video is copied back from GPU memory to normal memory. This requires extra CPU resources and memory bandwidth. Your Atom is too weak to handle that extra load.

Increasing the Subpicture buffer size in MPC-HC subtitle options might help a bit to further improve smoothness.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: High bitrates choppy with MPC-HC but fine with WMP (DXVA issue?!)

Post by Sponsored content Today at 5:44 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum