Clipping issue with aac audio in videos from youtube.

View previous topic View next topic Go down

Clipping issue with aac audio in videos from youtube.

Post by 123459 on Sun Sep 22, 2013 2:16 pm

The problem first appeared in 9.9.0 mega.
9.8.5 mega and below works fine.

setup:
windows xp sp3,
internal nvidia sound card based on alc650 (16bit dac)

Looks like that the cause of the problem lies in mpc-hc 1.6.8.xxxx and above.

Tried MPC-HC.1.6.7.7036 and MPC-HC.1.6.7.7112 - no issue;

MPC-HC.1.6.8.7123 - tried different aac decoders - both lav and ffdshow - issue present, no matter how i change input and output sample formats in audio decoder settings.

When i use ac3filter as aac audio decoder AND decrease Gain to -20dB, then clipping is absent in any mpc-hc 1.6.8.xxxx, even mpc-hc 1.7.0.7805 works fine.

Spoiler:
example file source: http://www.youtube.com/watch?v=gJlvf9n6f5g
file details:
Format                                   : Flash Video
File size                                : 30.3 MiB
Duration                                 : 5mn 50s
Overall bit rate                         : 724 Kbps

Video
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : Main@L3.0
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 3 frames
Codec ID                                 : 7
Duration                                 : 5mn 50s
Bit rate                                 : 593 Kbps
Width                                    : 640 pixels
Height                                   : 480 pixels
Display aspect ratio                     : 4:3
Frame rate mode                          : Constant
Frame rate                               : 30.000 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.064
Stream size                              : 24.8 MiB (82%)

Audio
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : 10
Duration                                 : 5mn 50s
Bit rate                                 : 123 Kbps
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 44.1 KHz
Compression mode                         : Lossy
Stream size                              : 5.13 MiB (17%)

123459

Posts : 4
Join date : 2013-09-22

View user profile

Back to top Go down

Re: Clipping issue with aac audio in videos from youtube.

Post by Admin on Mon Sep 23, 2013 4:00 am

The version of MPC-HC has no effect on how AAC audio is decoded, unless you are using its internal audio boost/normalize functionality,

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Clipping issue with aac audio in videos from youtube.

Post by Admin on Mon Sep 23, 2013 4:04 am

Which downloading tool are you using? Some tools fuck up the files.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Clipping issue with aac audio in videos from youtube.

Post by Admin on Mon Sep 23, 2013 4:11 am

I have downloaded the same video, and I get no clipping.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Clipping issue with aac audio in videos from youtube.

Post by 123459 on Mon Sep 23, 2013 3:10 pm

Admin wrote:The version of MPC-HC has no effect on how AAC audio is decoded, unless you are using its internal audio boost/normalize functionality,
where it can be found?
UPD: found it

what i did:

1. downloaded k-lite mega codec pack 10.0.5 from http://www.techspot.com/downloads/615-klite-mega-codec-pack.html using opera 12.15, md5 of downloaded file F85B2942CFA7FD869E5FAE825496576E
2. run setup in normal mode, deselected all, then selected only folowing components: mpc-hc 1.7.0.7805, flash video[ffdshow], aac[ffdshow], mp4 splitter[lav], then clicked next all the time without changing  default settings.
3. downloaded flash video file, md5 of file: F3F1EE110E5193CFB34B44532FD6A6AB
4. double clicked on downloaded file - issue present.
I did not change any setting in mpc-hc - just opened the file

5. fully uninstalled codec pack using "Uninstall K-Lite Codec Pack" shortcut

6. downloaded k-lite mega codec pack 9.8.5
7. installed it using same settings, as described above
8. opened flash video file - no issue.

9. uninstalled codec pack 9.8.5

10. installed mega codec pack 10.0.5 without mpc-hc, rest of the settings was the same: flash video[ffdshow], aac[ffdshow], mp4 splitter[lav], then clicked next all the time without changing default settings.
11. downloaded mpc-hc 1.6.7.7036 from http://nightly.mpc-hc.org/old/1.6.7/1.6.7.7036/MPC-HC.1.6.7.7036.x86.exe
12. installed it with default settings
13. opened it via shortcut and disabled all internal filters, so it would use k-lite ones
14. closed it
15. opened flash video file - no issue

UPD: well, this is default setting for mpc-hc 1.7.0+  , checked it twice - in K-Lite_Codec_Pack_1005_Mega and in standalone http://nightly.mpc-hc.org/old/1.7.0.7805/MPC-HC.1.7.0.7805.x86.exe (i fully uninstalled codec pack along with the settings, before installing standalone player).

123459

Posts : 4
Join date : 2013-09-22

View user profile

Back to top Go down

Re: Clipping issue with aac audio in videos from youtube.

Post by 123459 on Mon Sep 23, 2013 3:40 pm

Also, if you ever wondering, why i download videos from youtube:
i dont download them, i use mpc-hc together with http://www.svp-team.com/wiki/SVPtube/en because flash player's seeking controls are lacking.

123459

Posts : 4
Join date : 2013-09-22

View user profile

Back to top Go down

Re: Clipping issue with aac audio in videos from youtube.

Post by Admin on Tue Sep 24, 2013 6:29 am

The boost slider should be all the way to the left. Now it is set to maximum volume boost.

If the slider is in that position even after resetting settings, it would mean there is some kind of weird bug in MPC-HC.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Clipping issue with aac audio in videos from youtube.

Post by 123459 on Wed Sep 25, 2013 9:27 am

Admin wrote:If the slider is in that position even after resetting settings, it would mean there is some kind of weird bug in MPC-HC.
i checked on clean windows xp install(in vm) - boost slider is at 0%, what is correct.
So, error was only on my current setup - maybe settings persisted somewhere. Anyway, with your notice, i now fixed it.

123459

Posts : 4
Join date : 2013-09-22

View user profile

Back to top Go down

Re: Clipping issue with aac audio in videos from youtube.

Post by Sponsored content Today at 7:09 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum