Problem with .mid

View previous topic View next topic Go down

Problem with .mid

Post by monarch63 on Sun Mar 17, 2013 1:17 am

I have the very last version of the pack

When i try to play a particular .mid (this one: mega.co.nz #!AldwQKxa!QuEJRThm-4UbcFPFKinAjBQXqoQFAdDBdQKyVgdR7WE ) there are sound missed (Il manque des sons)
With QuickTime player ( pale ) its is ok
and with Windows media player there is no sound ...

If there a solutin thank you

(sorry for my english)

Je suis pas très fort en expression écrite .

monarch63

Posts : 3
Join date : 2013-03-17

View user profile

Back to top Go down

Re: Problem with .mid

Post by Admin on Sun Mar 17, 2013 4:38 am

That file should play using standard codecs from Windows.

Which codecs are shown when you open that file in the GraphStudioNext tool?

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Problem with .mid

Post by monarch63 on Sun Mar 17, 2013 7:31 am

When I play it in GSN it is the same as if it was Classic Media Player some sounds dissapear

I guess that's it :

--------------------------------------------------
Filters
--------------------------------------------------
1. File Source (Async.)
File: blurry.mid
Type: Standard
CLSID: CLSID_AsyncReader {E436EBB5-524F-11CE-9F53-0020AF0BA770}

2. MIDI Parser
Type: Standard
CLSID: {D51BD5A2-7548-11CF-A520-0080C77EF58A}

3. Default MidiOut Device
Type: Standard
CLSID: {07B65360-C445-11CE-AFDE-00AA006C14F4}

--------------------------------------------------
Connections
--------------------------------------------------
1. [File Source (Async.)]/(Output) -> [MIDI Parser]/(Reader)
Major: MEDIATYPE_Stream {E436EB83-524F-11CE-9F53-0020AF0BA770}
Subtype: MEDIATYPE_Midi {7364696D-0000-0010-8000-00AA00389B71}
bFixedSizeSamples: TRUE
bTemporalCompression: FALSE
lSampleSize: 1
cbFormat: 0
Format: GUID_NULL {00000000-0000-0000-0000-000000000000}

2. [MIDI Parser]/(Out) -> [Default MidiOut Device]/(Audio Input pin (rendered))
Major: MEDIATYPE_Midi {7364696D-0000-0010-8000-00AA00389B71}
Subtype: GUID_NULL {00000000-0000-0000-0000-000000000000}
bFixedSizeSamples: FALSE
bTemporalCompression: FALSE
lSampleSize: 1
cbFormat: 32
Format: GUID_NULL {00000000-0000-0000-0000-000000000000}



Media Info :

Format : MIDI
Format/Info : RIFF Musical Instrument Digital Interface
Taille du fichier : 62,0 Kio

Audio
Format : MIDI
Format/Info : RIFF Musical Instrument Digital Interface

monarch63

Posts : 3
Join date : 2013-03-17

View user profile

Back to top Go down

Re: Problem with .mid

Post by Admin on Mon Mar 18, 2013 3:11 am

Those are the correct filters. This is the way that all DirectShow players will play midi files. I don't have QuickTime to compare output. If sounds are truely missing, then the only thing I can think of that might help is to update your sound driver.

Admin
Admin

Posts : 2977
Join date : 2011-06-17

View user profile http://codecs.forumotion.net

Back to top Go down

Re: Problem with .mid

Post by monarch63 on Mon Mar 18, 2013 4:25 am

Ok , thank you .

monarch63

Posts : 3
Join date : 2013-03-17

View user profile

Back to top Go down

Re: Problem with .mid

Post by Sponsored content Today at 9:12 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum